Do Not Use Quotation Marks When Using Built-in Attachments Uploader

Discussion in 'Paphiopedilum' started by Heather, Jun 19, 2014.

Slippertalk Orchid Forum

Help Support Slippertalk Orchid Forum:

  1. Jun 19, 2014 #1

    Heather

    Heather

    Heather

    Administrator Staff Member Admin Moderator

    Joined:
    Jun 6, 2006
    Messages:
    12,441
    Likes Received:
    8
    Location:
    Sacramento, CA. Outside w/ Southeast Exposure
    Thanks to Tom Kalina and to Liquid Web (our amazing server support), we have discovered an issue with uploading photos using the built in attachment uploader.

    There is a rule built in to keep the server running smoothly called a ModSecurity rule that the attachment process was tripping. Apparently the attachment file had an illegal naming convention in it. If the filename has a single or double quote in it, it trips this rule and generates an error.

    When this is the case, then a simple rename of the file should allow you to upload the file.

    Of course this is an issue for us because of the use of single quotation marks around clonal names.

    For example, Tom's Phrag. vitattum 'Birchwood' jpg file had the quotes included in the name of the attachment which tripped the rule and caused the server error. When I removed the quotes around 'Birchwood', the photo uploaded just fine.

    So, please make sure when uploading attachments that your files do not have single or double quotation marks in the file name.

    Thank you!
     
    Last edited: Jun 20, 2014
  2. Jun 19, 2014 #2

    cnycharles

    cnycharles

    cnycharles

    Peloric keiki

    Joined:
    Jan 22, 2008
    Messages:
    9,576
    Likes Received:
    4
    Location:
    elmer, nj
    What an esoteric error
     
  3. Jun 19, 2014 #3

    mrhappyrotter

    mrhappyrotter

    mrhappyrotter

    Grand Chupacabra

    Joined:
    Dec 26, 2012
    Messages:
    2,234
    Likes Received:
    39
    Location:
    Central North Carolina
    Dealing with character encoding and providing support for various non-alphanumeric symbols is a pretty complex issue, so it doesn't surprise me.

    As a general rule, when it comes to files and directories I adhere to the KISS methodology, keep it simple, stupid. Stick with alphanumeric symbols, maybe an underscore and obviously the dot (.).

    On the other hand, when it comes to passwords, I approach with the opposite philosophy. Keep it random, and don't be afraid of the special characters and symbols.
     
  4. Jun 20, 2014 #4

    Heather

    Heather

    Heather

    Administrator Staff Member Admin Moderator

    Joined:
    Jun 6, 2006
    Messages:
    12,441
    Likes Received:
    8
    Location:
    Sacramento, CA. Outside w/ Southeast Exposure
    Tell me about it - we've probably experienced this since the forum started and I just never knew about it until now. Since we upgraded servers, I'm asking about any little issue that comes up and finding out all sorts of things I'd never have discovered on my own!
     
  5. Oct 3, 2016 #5

    cxcanh

    cxcanh

    cxcanh

    Well-Known Member

    Joined:
    Apr 30, 2010
    Messages:
    685
    Likes Received:
    37
    It tell us some information why it's not working sometime.
    Thank you
    @ We do have option that we post direct photos to the forum? I need to upload photo in other page then copy the link to this forum (so we will have one problem that is the photo page that I copy link have problem then all photo I post here also disappear)
     
  6. Feb 16, 2019 #6

    Heather

    Heather

    Heather

    Administrator Staff Member Admin Moderator

    Joined:
    Jun 6, 2006
    Messages:
    12,441
    Likes Received:
    8
    Location:
    Sacramento, CA. Outside w/ Southeast Exposure
    This may be obsolete now with the new software, but if it does come up, please let us know!
     
  7. Apr 5, 2019 #7

    Heather

    Heather

    Heather

    Administrator Staff Member Admin Moderator

    Joined:
    Jun 6, 2006
    Messages:
    12,441
    Likes Received:
    8
    Location:
    Sacramento, CA. Outside w/ Southeast Exposure
    Don't think this is an issue any longer but if it is, please let us know so we can get it fixed!
     

Share This Page



arrow_white